phpdocx requires PHP 5.2 or newer (phpdocx is compatible with all PHP versions from PHP 5.2.11 to PHP 8) to be installed in your server. Moreover the following PHP modules should be activated
PHP 7.0 or higher, PECL, Composer. grpc extension, protocol buffers compiler: for installation instructions, see the gRPC PHP readme. Get the example code.